UI Issue causing black screen after login

Incident Report for SaaS Alerts

Resolved

This issue has been resolved.
Posted Apr 13, 2026 - 09:28 EDT

Update

The issue is with overview page itself. Other pages such as https://manage.saasalerts.com/organizations works fine. Continuing to investigate.
Posted Apr 13, 2026 - 09:22 EDT

Investigating

We are currently investigating this issue.
Posted Apr 13, 2026 - 09:18 EDT
This incident affected: Manage.