SaaS Alerts UI SSL/Cloudflare Issue

Incident Report for SaaS Alerts

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 09:27 EST

Update

We are continuing to monitor for any further issues.
Posted Mar 04, 2026 - 09:27 EST

Monitoring

All access has been restored to the manage and reports UI.
Posted Mar 03, 2026 - 23:25 EST

Update

Manage UI is available again. Reports UI is being worked on now.
Posted Mar 03, 2026 - 23:09 EST

Update

Our team has identified the root cause, and is actively working towards resolution. All events are being processed as normal.
Posted Mar 03, 2026 - 22:44 EST

Identified

Our team has identified what we think is the root cause. We will update as soon as we have more information.
Posted Mar 03, 2026 - 21:44 EST

Update

We are continuing to investigate this issue.
Posted Mar 03, 2026 - 21:01 EST

Update

We are continuing to investigate this issue.
Posted Mar 03, 2026 - 20:09 EST

Investigating

We are currently investigating this issue.
Posted Mar 03, 2026 - 20:09 EST
This incident affected: Manage, Respond, and Reports.